• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

Ancient

CoH - Windows 10 problem

5 posts in this topic

So i am trying to play the Company of Heroes new steam version again, but now on windows 10. And for some reason it does not launch, steam says it did, but 20 seconds later it just says i am online, instead of playing it.

 

People said i should try to :

  • Validate game cache
  • run as admin
  • use compatibility mode
  • delete windows security update (The specific security update does not exist on windows 10, KB2670838 i remember i had to delete the update for it to work on windows 7)
  • replace xthread file
  • delete dx10.dll
  • change admin rights
  • launch with -nomovies

I try'd all off the above. Nothing seems to make the game run. It crashes at launch, not even a new window opens up. just does not run. but according to steam it does and soon crashes. The games Warning log does not report any errors neither. It also did not install direct x or anything first launch. I also made a thread on the steam forums, but no one gave me a answer. The game also seems not to work on windows 8. Anyone got any ideas?

Share this post


Link to post
Share on other sites

Did you reinstall the game since upgrading to Win 10? I had to do this with a lot of my games, but I can confirm the game does work on Win 10.

Share this post


Link to post
Share on other sites

Did you reinstall the game since upgrading to Win 10? I had to do this with a lot of my games, but I can confirm the game does work on Win 10.

I did a clean installation, i re-downloaded the game just yesterday. Do you have the game? i would really appreciate some assistance onto calculating the differences between my machine and yours. There must be something i am missing.

guess you have to downgrade?

If only i wanted and could do such a thing... I still wouldn't do it. Windows 10 is love. For some reason, i found out the devs put up a page on the forums to make it work on windows 8.1 by downloading DirectX End-User Runtimes (June 2010), when i did this, steam prompted me with the EULA of the game. and it took a little longer for it to crash. but it still crashed. Sadly.

I really could use some assistance.

 

Share this post


Link to post
Share on other sites

Recently I've had this recurring bug when I start up Coh2 on Windows 10 where the game starts but doesn't fill the screen up so to speak. I can hear the bootup sounds of Coh2 and the distinctive "sega" in the background but all I can visually see is a black screen that keeps alt tabbing itself in and out of the screen. About half the time I can manually alt tab back in to the main menu the bottom https://showbox.tools/ portion of the menu is cut off. It seems almost as if Coh2 is trying to launch in a different resolution almost and can't conform to my own screen resolution (1600x900) and keeps trying to by itself. Compatability settings does nothing in steam as running any of them causes a crash upon startup.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now