• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

Sign in to follow this  
Followers 0
Jon the VGNerd

PC dropped to 30fps on certain games after they were previously 60fps

19 posts in this topic

Specs are:

AMD Radeon R7 240 (3 GB)

AMD A10-6800K CPU

8 GB RAM

Lately, most of my games I played had a smooth 60 FPS but then, for unknown reasons, dropped down to 30 FPS and I'm unable to find anything to rectivy the issue. Even Catalyst Control Center refuses to open up after installing it (nVIDIA control panel is non-existent because none of my parts are related to nVIDIA at all). I even tried Postal 2, which had a 1024x768 resolution and when I changed it to 1600x900 as a native resolution, it kicked me into Windows Mode and when I switched to full screen, it redirected back to 1024x768 with the same, choppy 30fps. As unusual as it sounded, I tried to Google it with no such luck and the results I had are people who have similar problems like I do.

I originally had 60GHz as well, but then it was now 4.10GHz for unexplained reasons. Is there any solution to fix the FPS issue for the majority of my games so I can get a stable 60fps again? I tried downloading the drivers, no fix as it told me that I already have the latest drivers installed.

Share this post


Link to post
Share on other sites

Could be symptoms of many things. Worst case your GPU or CPU may be dying, best case it's a driver problem.

Share this post


Link to post
Share on other sites

Could be symptoms of many things. Worst case your GPU or CPU may be dying, best case it's a driver problem.

Weird... my CPU is hardly a year old as I had it upgraded from A10-6700 for a slightly better speed. Maybe I could give it a bit of maintenance and see?

Share this post


Link to post
Share on other sites

Weird... my CPU is hardly a year old as I had it upgraded from A10-6700 for a slightly better speed. Maybe I could give it a bit of maintenance and see?

Like I said, that would be the worst case and the issue is most likely software.

Share this post


Link to post
Share on other sites

Like I said, that would be the worst case and the issue is most likely software.

If it is, is there any way to fix it? Like, uncovering the PC and give it a bit of cleaning, or upgrade the motherboard?

Share this post


Link to post
Share on other sites

I'm not quite sure how you were getting 60FPS in most of your games in the first place!  I just did a quick search myself and it seems that most people with a R7 240 aren't getting that getting that kind of performance unless the resolution and/or settings are turned down really low. Did you change any other in game settings?

 

BF4-FR.png

 

74220.png

Share this post


Link to post
Share on other sites

I'm not quite sure how you were getting 60FPS in most of your games in the first place!  I just did a quick search myself and it seems that most people with a R7 240 aren't getting that getting that kind of performance unless the resolution and/or settings are turned down really low. Did you change any other in game settings?

 

BF4-FR.png

74220.png

Nope, they just changed on their own out of nowhere, no warning either.

Share this post


Link to post
Share on other sites

Nope, they just changed on their own out of nowhere, no warning either.

 

You seem to have exhausted most of the software trobleshooting so It could be a power or heating issue.  All I can suggest right now is to take a look inside for hardware faults like loose connections and make sure the fan on the card is working.

Share this post


Link to post
Share on other sites

You seem to have exhausted most of the software trobleshooting so It could be a power or heating issue.  All I can suggest right now is to take a look inside for hardware faults like loose connections and make sure the fan on the card is working.

I see. And if anything, I should give it thorough cleaning, right?

EDIT: I cleaned everything, the connections were fitted with no issues and hardware is fine as well. Unfortunately, I still got a woeful 30fps on several games so if the motherboard's having issues, then I intend on giving it full upgrades, but at this time, money's an issue. Oh well.

Share this post


Link to post
Share on other sites

I see. And if anything, I should give it thorough cleaning, right?

You could, but it's probably not needed.

Share this post


Link to post
Share on other sites

You could, but it's probably not needed.

Yeah. I checked everything and everything looks intact. No loose connection or signs of tampering, nothing serious except I still got 30fps instead of the usual 60fps on several games. If I play it on windowed mode, I get a smooth 60fps but if I try and play it at full screen, it suddenly drops to a questionable 30fps.

Share this post


Link to post
Share on other sites

Yeah. I checked everything and everything looks intact. No loose connection or signs of tampering, nothing serious except I still got 30fps instead of the usual 60fps on several games. If I play it on windowed mode, I get a smooth 60fps but if I try and play it at full screen, it suddenly drops to a questionable 30fps.

I'm not going to call this a permanent fix but it might do in the short term until we can figure out the problem. There is app in the steam store called Borderless Gaming and essentially what it does in run Windowed apps in a false full screen. It's primarily designed for people who use multiple monitors but it should work for this to.

Share this post


Link to post
Share on other sites

I'm not going to call this a permanent fix but it might do in the short term until we can figure out the problem. There is app in the steam store called Borderless Gaming and essentially what it does in run Windowed apps in a false full screen. It's primarily designed for people who use multiple monitors but it should work for this to.

Right, I'll go and take a look-see.  :)

Share this post


Link to post
Share on other sites

Bought Borderless Gaming today and it did not help the FPS issue on certain games. It only works if its on Windowed Mode, but on Full Screen, the issue still remains.  :(

EDIT: Maybe I could try reinstalling my graphics driver if the new update doesn't work?

Share this post


Link to post
Share on other sites

Bought Borderless Gaming today and it did not help the FPS issue on certain games. It only works if its on Windowed Mode, but on Full Screen, the issue still remains.  :(

EDIT: Maybe I could try reinstalling my graphics driver if the new update doesn't work?

 

When I read this, First thing that comes to mind is definitely Drivers. Have you updated recently?

 

Also, Do you use Raptr or whatever AMD's 'performance' app is?

I use to and it auto-set everything and screwed up all my tweaking; Had a similar problem.

Share this post


Link to post
Share on other sites

When I read this, First thing that comes to mind is definitely Drivers. Have you updated recently?

 

Also, Do you use Raptr or whatever AMD's 'performance' app is?

I use to and it auto-set everything and screwed up all my tweaking; Had a similar problem.

I updated it and it seems that it successfully fixed the FPS issue! :D

Share this post


Link to post
Share on other sites

I updated it and it seems that it successfully fixed the FPS issue! :D

Awesome, happy to help mate~ (Upgrade to Nvidia tho)

Share this post


Link to post
Share on other sites

Awesome, happy to help mate~ (Upgrade to Nvidia tho)

Mmhm!

(Also, I would use Nvidia when I build my own PC, but even Nvidia can't handle certain games like Arkham Knight for example. :P)

Share this post


Link to post
Share on other sites

Back tracking my drivers did not solve my problems, nor updating it :'(

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0