• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

DAHFAN1308

Laptop help

2 posts in this topic

My grandparents found a Dell Inspiron 15 Inspiron 7000 series 7548 in a storage locker. They gave it to me and wanted me to fix it, but I need some help. I let it charge for 1 day and then turned it on. It showed the Dell screen and took about a half hour to load. Then it took me to the Windows 10 safe mode. No matter what I do, it either repeats the boot system from the Dell logo to Windows safe mode, it tries to find disk errors but fails, find reboot errors but fails, or will take me to the Motherboard screen where I learned it has some kind of an i5 and 6gb of RAM. If anyone can think of a solution any help is appreciated, 

Share this post


Link to post
Share on other sites

Sounds like the HDD might may have gone the way of platform shoes.  I'd replace it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now