• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

darksiders005

Assassin's Creed Origins Issues with Uplay

4 posts in this topic

Uplay has made it impossible to play Assassin's creed Origins with the game simply not opening with uplay

people have no idea why this is happening i am one of meany people with this issue i don"t believe this is a hardware issue 

simply because meany people have relatively the same set up but do not have this issue i could be wrong but i have no issue with any other uplay game 

just this one it only when it flickers to the a different uplay screen then nothing happens.

https://steamcommunity.com/app/582160/discussions/0/1480982338948611639/

Share this post


Link to post
Share on other sites

I haven't played in a few days but it was working fine for me the last time I tried, I'll check it later.

 

EDIT:  Now that I have reclaimed my UPlay account from some Dutch dope addict I'm now having this issue to.

Share this post


Link to post
Share on other sites

I just re-installed, a pain in the ass but it worked.

Share this post


Link to post
Share on other sites

I have tryed 3 or 4 different times and nothing changes and iv reinstalled uplay as well iv also tryed moving it to my normal computer hard drive and noooooop nothing changes just gota wait for a patch like very other game that has issues nower days :) and thank you for you help nice to have some on the look out for these issues

Edited by darksiders005

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now