• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

Sign in to follow this  
Followers 0
Tidell

PC very slow to start

3 posts in this topic

Hello AJSA

For the last 2 weeks my PC has been very slow to startup.
I type in my password and the welcome text pops up for about 15 seconds and then the screen goes black for around 1-2 minutes. I can still see my cursor and move it around.
Does anyone know what is causing this , is it my SSD maybe?

 

Thx 

Share this post


Link to post
Share on other sites

I find it unlikely that your SSD boot drive (assuming that's how it's set up) is at fault. There's very little that can go wrong with them and a failure of the boot drive would be more crippling than what you describe. It's more likely to be a connection problem. Loose and/or damaged connectors on the SATA cable or possibly a problem with the SATA cable itself. Check the connections and try alternative SATA cables if you can. If that doesn't help, it may be a problem with the CPU, RAM or motherboard, but if the PC works fine otherwise than that isn't very probable. 

Tidell likes this

Share this post


Link to post
Share on other sites
16 minutes ago, Shagger said:

I find it unlikely that your SSD boot drive (assuming that's how it's set up) is at fault. There's very little that can go wrong with them and a failure of the boot drive would be more crippling than what you describe. It's more likely to be a connection problem. Loose and/or damaged connectors on the SATA cable or possibly a problem with the SATA cable itself. Check the connections and try alternative SATA cables if you can. If that doesn't help, it may be a problem with the CPU, RAM or motherboard, but if the PC works fine otherwise than that isn't very probable. 

Thank you Shagger , i'll look into it :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0