• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

Sign in to follow this  
Followers 0
Krystalon

Skyrim bug that I really need help fixing

11 posts in this topic

Ok so here is the thing, I recently was playing skyrim and started a new character, my redgaurd by the name of Altarkur was captured by the imperials. After all escaping with the stormcloak and getting told by his sister to get help from whiterun for riverwood. Altarkur was so exited to meet the famous trading hub of skyrim. As he walked into the city he noticed something in the sky "Is that water" he thought to himself, as he walked to the gildergreen he became surrounded in water that appeared in thin air! Thus ends the journey of the dragonborn.

 

That out of the way I want to discuss the bug, As I was wondering in whiterun I noticed a block of water above the center of whiterun, at first I thought it was a bad texture but as I was going to the jarl I started swimming, in the center of whiterun and I watched as helpless people floated atop. 

 

I have searched this bug and seems that no one has encountered this bug (If anyone has then I am glad that it is not just me). I really need assistance to fix this mod or my favorite city will become rapture, and we all know that is not a good thing.

 

If anyone knows a hint on how to fix this POST RIGHT NOW AND DON'T THINK TWICE!!!!

Please I need help to fix this mod, badly.

Share this post


Link to post
Share on other sites

Um...what mod are you referring to?

I am not referring to a mod but a bug or glitch, let me re-phrase it

 

In whiterun, there is a block of water above the city, and when I walk deeper into the city, Water appears out of nowhere and I begin to swim.

so far I have seen that the water ends at the stairs to the keep

So.....I really need help to fix this

Share this post


Link to post
Share on other sites

Pc or console, and if pc do you have any mods running, if so can you list them.

Share this post


Link to post
Share on other sites

Pc or console, and if pc do you have any mods running, if so can you list them.

PC, I run 70 mods....all for enchanced gameplay.

I cannot list them all right now because I am not at my house which means my rig will not be available.

I will try to reply as soon as I get home, if not today maybe tomorrow or the day after that

Thanks for replying btw

Share this post


Link to post
Share on other sites

PC, I run 70 mods....all for enchanced gameplay.

I cannot list them all right now because I am not at my house which means my rig will not be available.

I will try to reply as soon as I get home, if not today maybe tomorrow or the day after that

Thanks for replying btw

it could be that mods are conflicting with each other, it's even harder to fix due to it being water. Im not even sure water can be targeted threw console commands so your best bet is to disable one mod at a time to see if that fixes it. Also check to see if there are any updates to the mods you use.

Share this post


Link to post
Share on other sites

it could be that mods are conflicting with each other, it's even harder to fix due to it being water. I'm not even sure water can be targeted threw console commands so your best bet is to disable one mod at a time to see if that fixes it. Also check to see if there are any updates to the mods you use.

Well, I have turned off all my Water mods such as "Pure water" (the one I use) and "water" which are not on at the same time.

I use boss to organize the mods and to tell me if they conflict or add specific water to whiterun but it comes up with zilch 

I was wondering if I would be able to use the creation kit to target the water and delete it from there instead of using the console commands, but If I were able to do that I might target the wrong types of water as there are many in whiterun. and seeing how the water only appears as a little box in the air and then appearing all around me when I apparently go into it, makes it even harder to do

Share this post


Link to post
Share on other sites

It does sound like a mod conflict or corrupt mod.

 

Run TES5Edit and see if that comes back with any errors. I find it does a better job than BOSS.

 

Then use that program or Wrye Bash to make a bash patch (merged patch) that tells all your mods to play nice together.

 

Silly thing to say but it is surprising how many mod users don't use it, make sure you have Skyrim Script Extender. 

Share this post


Link to post
Share on other sites

It does sound like a mod conflict or corrupt mod.

 

Run TES5Edit and see if that comes back with any errors. I find it does a better job than BOSS.

 

Then use that program or Wrye Bash to make a bash patch (merged patch) that tells all your mods to play nice together.

 

Silly thing to say but it is surprising how many mod users don't use it, make sure you have Skyrim Script Extender. 

Thanks, Ill try it and reply to see if it has worked, and yes I have SKSE, but I just have two question.

Is Wyrebash better to use to do the merged patch than tes5edit and will it conflict with Nexus Mod Manager? 

thanks for your help again

Share this post


Link to post
Share on other sites

Thanks, Ill try it and reply to see if it has worked, and yes I have SKSE, but I just have two question.

Is Wyrebash better to use to do the merged patch than tes5edit and will it conflict with Nexus Mod Manager? 

thanks for your help again

No there is no conflict between wrye bash and mod manager. I use them all.

 

Wrye Bash does have more options when it comes to merging a patch than TES5Edit does but the patch itself works no matter which program you use. To be fair, TES5Edit is probably the better one to use as Wrye Bash can overcomplicate things sometimes.

 

I would say to run TES5Edit first and see if that comes up with an error. Unlike BOSS it won't finish reading mods if an error does come up and will tell you what the error is and if any files are corrupt or missing.

 

The only other way I can think of is to start fresh with no mods, wait until you get access to Whiterun again and then make a clean save. Load up your mods a few at a time to see which one it is that causes the glitch.

 

Than one can be annoying and does take time (I run over 200 mods and had to do it that way once).

Share this post


Link to post
Share on other sites

I had a similar problem, where I would find myself walking on thin air in the vicinity of Lost Echo Cave (NW side of the map). I similarly had about 80 mods running, and none of them appeared to be conflicting at first glance. I tried verifying local files through steam, which found a few corrupt files, but the problem persisted. The weird thing is that the problem persisted with only one character. Every other savegame I had was working fine in that area (including prior savegames for the particular character with which I encountered the bug)

It wasn't interferring with any of my gameplay, since I had done all I could in that area, so I left it be for a while. Recently, I had to format my PC, and I thought to check and see if the problem was resolved. The problem persisted in the savegame, even in the vanilla game, but all other savegames were fine as before.

My guess is that some graphics enhancement tool had run havok for some reason, and overwrote something in the world of my savegame. I suggest you try visiting that area with another character and see if the bug is universal, or specific for only one character. If it's specific then you have a problem, since it will be hard-written in your savegame. If it's universal, then you can probably fix it through installing/uninstalling all mods in your game (worst case: reinstall the game + the mods from the beginning), and checking each time to see if things are ok or not. Also, if the bug is specific, you should try reloading older savegames and see if the problem appears there. It would probably be more time-saving if you just started again from a previous savepoint, than sitting down to fix the problem. Otherwise, you can always try and see if the mod files themselves have some conflicting line in their programming, but that's even more time-consuming.

 

So, you should do the following in this order for as long as the problem persists:
1) Verify local files through steam

2) Post your problem in the forums where you got each of your mods. If it's a mod conflict, probably someone else has encountered it and they'll say so there. You'll get to know which mod caused the bug and probably how to fix it easily. It's important to do this as early as possible in the process, so that while you wait for a reply, you can do your own troubleshooting, and if you can't find a solution, then probably someone will point you to the right direction by the time you finish step 3-4.

3) Check to see if you can resolve the problem through the use of a world editor. I think there's a couple out there that don't require item IDs. Just make sure to save your game prior, in case something weird happens that you can't fix.

4) Check your hardware to see if anything overheats. Sometimes hardware (usually graphics card) malfunction causes games to behave in very weird ways and display persistant bugs. If you are not using a laptop, check the connections of your internal wiring, clean the cartridge slots for each hardware you got (namely the graphics card and then the RAM), and check if your CPUs heatsink is fine. If it's an overheating issue, try using a little program called SpeedFan, which is excellent at controlling your computer fans. Make sure you know how to set it up first, and also uninstall any other program that controls your fan speeds (except your Drivers). Particularly, the ATI catalyst control centre has been known to be the culprit in many issues ranging from bugs to total system failures. I suggest you uninstall it and see if things get fixed. Don't worry it doesn't carry any drivers, you'll just lose some of the ability to fully customize your graphics card's work details.

5) Check your savefiles to see if the problem is character/save-specific or universal. If it is, you'll probably be better off restarting from a previous savepoint.

6) Check to see if any of the mods got recent updates, they would probably be the culprits, try to uninstall them.

7) Uninstall mods one by one and see which one causes the problem (start from the latest updated one, and work your way down)

8) Uninstall the game and reinstall it and see if the problem persists

9) Start reinstalling mods one by one, prefferably in a random order (if it was more than 1 mods conflicting with each other and escaped you during uninstallation, it'll probably show up now) and check whether the game is fine or not after each reinstall

10) Try and check the command lines for each mod, if you have a knack for these kinds of things. A debugger would be useful. If you don't know how to do it or if you are bored, better skip this step, it's a pretty long-shot.

 

Good luck, hope this helps

 

(EDIT: forgot to mention #3)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0