• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

Sign in to follow this  
Followers 0

Watch Dogs game won't start problem

1 post in this topic

I have a problem with the game, it will not start. I've had this game for 5 days and it has worked fine up until now. I ordered it from Amazon UK.
I tried to get on it and it just stopped at a certain part of Loading screen and won't load, then a trophy called "Gelocated" unlocked (It's for visiting all 100 hotspots), I have only visited 60 of them from playing before.
I tried waiting, closing application and trying it again, restart the PS4, removing the disk. What's wrong with it?
EDIT: I didn't mention, it's after I press continue, that loading screen. 

I have all guns and clothes, finished most of the side missions, am at the end of Act II, 50% total progression and a very high noreity (Top 1%) so I really don't want to loss everything.

Share this post

Link to post
Share on other sites
Sign in to follow this  
Followers 0