• Welcome to the Angry Joe Show Army!

    Join our community of gamers passionate about our community and our hobby! Whether it's playing, discussing, or watching games, regardless of platform, genre, or location, we have a place for you, always!

  • PS4 Forum

    The AJSA Playstation 4 Division: Game Nights and More!

    The AJSA is on Playstation 4! Join us for weekly Game Nights with a selection of the best games the PS4 has to offer!

  • XBO Forum

    The AJSA Xbox One Division: We Got You Covered!

    The AJSA Xbox One Division is ready to connect with you on XBox Live with a ton of events for the best Xbox games!

  • News Archive

    The Best News from the Best Sites, Every Week.

    The AJSA News Collection Team is hard at work condensing a week's worth of news into one giant-sze digest for you to chew on and discuss! Links to source articles are always provided!

  • More Info

    The AJSA Expeditionary Force: Deploying to Play the Best PC Games!

    The elite vanguard of the AJSA, the Expeditionary Force (EF) chooses a new PC game every week! Join us for weekly events and help decide if the game has a future in the AJSA.

  • The Team

    Streaming Now: The AJSA Stream Team

    Joe can't stream every game, but our talented AJSA Stream Team covers a wide variety of games and personalities! Check them out, and show them some AJSA Love!

  • The Tube

    The AJSA Community YouTube Channel

    Featuring news, gameplay clips, and more from the community! The Community is a chance to showcase the best moments in AJSA Gaming!

Sign in to follow this  
Followers 0
YORKSHIRE1993

Bad connection to Battlefront Xbox One servers?

5 posts in this topic

I have another 5 days to wait for Battlefield 1, so in the mean time I felt like giving Battlefront a bash, since I had bought the new Death Star DLC and everything, but I've noticed the game tonight has been effectively unplayable, I've been plagued with a bad connection to the servers and significant lag/rubber banding, this has never been an issue before with my BT Home Hub 3 connection, it's a strong connection, and Battlefront has worked perfectly fine in the past, so I have no idea why I had such a crappy connection to the server tonight, I checked my internet strength and Xbone said everything was fine and normal, it's really annoying me now, because I actually quite like Battlefront, despite its flaws. Has anyone else had this, and/or can tell me why I'm getting this when I've never had it before.

Share this post


Link to post
Share on other sites

Hey there,

Sorry to hear that you've been having issues. It may well be the game's servers acting up. I'll try it out tonight myself and report back just so you can see if this is happening to me as well etc. Have you tried to play at all since you posted this thread?

Share this post


Link to post
Share on other sites

It's been fine today, so I have no idea why it was being funny, maybe the servers were just having a paddy yesterday.

Share this post


Link to post
Share on other sites

Got on for a bit last night after Destiny. Servers seemed good, connection was alright. However I found that the DH-17 sorta no good now? Used to rock with that pistol but couldn't get any kills. Rust from not playing in awhile? Rampant use of personal shields? or did they just nerf the gun?

:corpcom:

Share this post


Link to post
Share on other sites

might not be as OP as it used to be, but still pretty damn strong, I got 3 kills in about 10 seconds with one a few hours ago.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0